jeudi 30 avril 2015

[Excel] Convertir une date en texte : la bonne formule

icône d'un document ExcelVoici un petit problème assez courant de conversion avec Excel : vous souhaitez convertir une date, qui est stockée dans une cellule au format date, afin qu'elle soit affichée dans une autre cellule, mais cette fois au format texte. Comment faire ?


Formules pour Excel 2007 Excel 2010 Excel 2013

capture d'écran ExcelSouvent avec Excel, certains problèmes apparemment compliqués ont une solution toute simple : il suffit d'utiliser la bonne fonction dans la bonne formule. C'est le cas pour ce problème de conversion, et la bonne fonction ici, c'est la fonction TEXTE.

Et voici les bonnes formules, en fonction du texte que vous souhaitez afficher : avec le jour ou le mois en nombre avec ou sans zéro significatif, avec le nom du jour ou du mois abrégé ou non, avec l'année à deux ou quatre chiffres, dans tel ou tel ordre, etc.

Dans ces formules, remplacez simplement la référence à la cellule A1 par la référence à votre cellule contenant une date. Pour des résultats personnalisés différents, vous pouvez bien sûr adapter les formules (voir le dernier exemple).

Jeudi 2 juillet 2015
=TEXTE(A1;"jjjj j mmmm aaaa")

Jeudi 02 juillet 2015
=TEXTE(A1;"jjjj jj mmmm aaaa")

Jeu 02 juillet 2015
=TEXTE(A1;"jjj jj mmmm aaaa")

Jeu 02 juil 2015
=TEXTE(A1;"jjj jj mmm aaaa")

02-juil-2015
=TEXTE(A1;"jj-mmm-aaaa")

02-07-2015
=TEXTE(A1;"jj-mm-aaaa")

02/07/15
=TEXTE(A1;"jj/mm/aa")

2015 / 02-juil
=TEXTE(A1;"aaaa / jj-mmm")

2015-07-02
=TEXTE(A1;"aaaa-mm-jj")

Année 2015 - mois de juillet, le 2
="Année "&TEXTE(A1;"aaaa")&" - mois de "&TEXTE(A1;"mmmm")&", le "&TEXTE(A1;"j")

Articles populaires