dimanche 8 avril 2018

[ Excel ] Convertir une date en texte : les bonnes formules

Excel[ Article mis à jour en avril 2018 ]
Voici un petit problème assez courant de conversion avec Excel : vous souhaitez convertir une date, qui est stockée dans une cellule avec le format date, afin qu'elle soit affichée dans une autre cellule (de la même feuille ou d'une autre feuille), mais cette fois au format texte. Comment faire ?


Formules pour Excel 2007 Excel 2010 Excel 2013 Excel 2016


capture d'écran ExcelTrès souvent, avec Excel, certains problèmes apparemment compliqués ont une solution toute simple : il suffit d'utiliser la bonne fonction dans la bonne formule.

C'est exactement le cas pour ce problème de conversion. Et la bonne fonction ici, c'est la fonction TEXTE.

Et voici les bonnes formules, en fonction du texte que vous souhaitez afficher : avec le jour ou le mois en nombre, avec ou sans zéro significatif, avec le nom du jour ou du mois abrégé ou non, avec l'année à deux ou quatre chiffres, dans tel ou tel ordre, etc.

Dans ces formules, remplacez simplement la référence à la cellule A1 par la référence à votre cellule source contenant une date.

Pour des résultats personnalisés différents, vous pouvez bien sûr adapter les formules (voir le dernier exemple).

dimanche 8 avril 2018
=TEXTE(A1;"jjjj j mmmm aaaa")

dimanche 08 avril 2018
=TEXTE(A1;"jjjj jj mmmm aaaa")

dim 08 avril 2018
=TEXTE(A1;"jjj jj mmmm aaaa")

dim 08 avr 2018
=TEXTE(A1;"jjj jj mmm aaaa")

08-avr-2018
=TEXTE(A1;"jj-mmm-aaaa")

08-04-2018
=TEXTE(A1;"jj-mm-aaaa")

08/04/2018
=TEXTE(A1;"jj/mm/aa")

2018 / 08-avr
=TEXTE(A1;"aaaa / jj-mmm")

2018-04-08
=TEXTE(A1;"aaaa-mm-jj")

Année 2018 - mois de avril, le 8
="Année "&TEXTE(A1;"aaaa")&" - mois de "&TEXTE(A1;"mmmm")&", le "&TEXTE(A1;"j")


Et pour "mois de avril" ? Peut-on obtenir un plus correct "mois d'avril" ? Bien sûr !

Là encore, pensez "formule" et "fonction", après avoir analysé le problème.

Il n'y a que trois mois dans l'année dont le nom commence par une voyelle : avril, août et octobre. Donc, pour ces trois mois, il faut indiquer d suivi d'une apostrophe et non pas de. Et donc, il faut une formule qui teste le nom ou le numéro du mois (le numéro, c'est plus simple). Et la fonction appropriée à associer, c'est la fonction MOIS (en plus, bien sûr, des fonctions de logique pour le test, ici OU et SI).

Et cela donne la formule suivante (qui n'est pas très facile à lire, mais elle fonctionne) :

="Année "&TEXTE(A1;"aaaa")&" - mois "&SI(OU(MOIS(A1)=4;MOIS(A1)=8;MOIS(A1)=10);"d'";"de ")&TEXTE(A1;"mmmm")&", le "&TEXTE(A1;"j")


Articles populaires